树莓派B+ debian wheezy安装gcc 4.8

安装了nodejs 5.0之后,node-gyp编译各种东西都报错,被逼无奈必须想办法安装到gcc 4.8以上。以下搬运下一位国外老兄的文章,按照步骤做完美解决问题。

把内容替换为

添加preferences文件

插入下列文本

更新apt包

从jessie仓库中安装 gcc/g++ 4.8

移除 gcc/g++ 版本选择配置 (默认没有其他版本选择,这里执行移除操作是以防万一)

安装并更新gcc 4.8到gcc可选版本

现在gcc已经默认指向gcc 4.8。使用下列命令来验证

如果你想切换gcc默认版本,可以执行下列命令

现在node-gyp可以正常运作了~

Leave a Comment

*